This project has moved. For the latest updates, please go here.
1

Closed

Require .net framework 3.5, but doc. says 2.0

description

I usually build apps for 2.0, And I do not think there is so much requirement of 3.5 framework for this library. Is it possible to make it back to 2.0.

Thank you.
Closed May 14, 2014 at 12:37 AM by PandaWood
ExceptionReporter relies heavilly on language features built into .NET3.5 and the WPF version is also baked into the codebase - hence we could not possibly accomodate going backwards in this way.

comments

PandaWood wrote Mar 24, 2014 at 4:24 AM

Actually, I couldn't put the .NET framework back to 2.0 as fairly basic language features only become available as of .NET 3.5 - such as extension methods, object initializers, lambda expressions etc and I use all these in the ExceptionReporter code base.

Plus I have a WPF version (although not finished) baked into the codebase as well.

So the requirement for .NET 3.5 is definitely in this library.